Skip to main content

Vaadake, milline versioon paketist on Ubuntu installitud

Vaadake, milline versioon paketist on Ubuntu installitud

Geoffrey Carr

Ubuntu pakettide haldamise süsteem muudab pakettide installimise ja eemaldamise väga lihtsaks, kuid mõnikord on oluline välja selgitada, milline konkreetse paketi versioon on tegelikult installitud.

Kleebitud utiliidid on lihtsalt debiani dpkg-utiliidi esiosa, mis tegelikult teeb tõelist tööd. Selle utiliidi abil saate teada, milline versioon on installitud.

dpkg -s

Siin on näide, kus ma proovisin välja selgitada, milline Ruby I versioon oli minu süsteemile installitud:

[email protected]:~$ dpkg -s ruby1.8

Package: ruby1.8Status: install ok installedPriority: optionalSection: interpretersInstalled-Size: 272Maintainer: Ubuntu Core Developers Architecture: i386Version: 1.8.4-5ubuntu1.2Depends: libc6 (>= 2.4-1), libruby1.8 (>= 1.8.4)Suggests: ruby1.8-examples, rdoc1.8, ri1.8Description: Interpreter of object-oriented scripting language Ruby 1.8Ruby is the interpreted scripting language for quick and easyobject-oriented programming. It has many features to process textfiles and to do system management tasks (as in perl). It is simple,straight-forward, and extensible..This package provides version 1.8 series of Ruby..On Debian, Ruby 1.8 is provided as separate packages. You can getfull Ruby 1.8 distribution by installing following packages..ruby1.8 ruby1.8-dev ri1.8 rdoc1.8 irb1.8 ruby1.8-elispruby1.8-examples libdbm-ruby1.8 libgdbm-ruby1.8 libtcltk-ruby1.8libopenssl-ruby1.8 libreadline-ruby1.8Original-Maintainer: akira yamada

Näete, et mul on installitud versioon 1.8.4.

Link
Plus
Send
Send
Pin